CronJobs

Hola a tod@s,

llevo aproximadamente un año utilizando este hosting gratuito y me ha surgido un problema:
- tengo una serie de archivos php que se ejecutan una/varias veces al día
- desde hace un año aproximadamente se han ejecutado sin problema
- hace un mes se habían borrado los cronjobs, supongo que por algún cambio en el servidor
- los volví a configurar y todo bien
- este lunes, día 8 de julio, se ejecutaron por última vez y no se han vuelto a lanzar
- no he modificado nada en esos archivos que se ejecutan desde hace mucho tiempo
- el archivo de error que se genera en el directorio public contiene:

PHP Warning: require_once(/ads/code.php) [<a href='function.require-once'>function.require-once</a>]: failed to open stream: No such file or directory in PHP Script on line 1
PHP Fatal error: require_once() [<a href='function.require'>function.require</a>]: Failed opening required '/ads/code.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in PHP Script on line 1
PHP Fatal error: Error occurred while executing PHP code, ERR - 101 in Unknown on line 0

¿cuál puede ser la causa?, ¿tengo que añadir algo a mis archivos que antes no era necesario?

Saludos
Ese error quiere decir que el archivo code.php (situado en el directorio ads) no existe. No lo habrás borrado sin querer o lo habrás cambiado de directorio?
Doodleo escribió:Ese error quiere decir que el archivo code.php (situado en el directorio ads) no existe. No lo habrás borrado sin querer o lo habrás cambiado de directorio?

¿Yo, como usuario, tengo acceso a ese archivo/directorio?, al menos no lo veo, ni el directorio ni, por supuesto, el archivo, ¿dónde debería buscar?
Entonces probablemente sea un archivo del servidor (que tú no puedes modificar) y ellos al hacer una actualización o algo resetearon, prueba a hablar con el soporte técnico del hosting a ver si te pueden aclarar algo más.

Aunque puedes probar a crear el directorio ads con el archivo code.php en blanco a ver qué pasa xD

Saludos y suerte!!
Doodleo escribió:Entonces probablemente sea un archivo del servidor (que tú no puedes modificar) y ellos al hacer una actualización o algo resetearon, prueba a hablar con el soporte técnico del hosting a ver si te pueden aclarar algo más.

Aunque puedes probar a crear el directorio ads con el archivo code.php en blanco a ver qué pasa xD

Saludos y suerte!!
La razón de venir a preguntar aquí es porque "ellos" me lo indicaron:
hola

En el caso del hosting gratuito el soporte es mediante el foro de la comunidad de http://www.comocreartuweb.com/consultas/forumdisplay.php/49-Hosting…

la gente de comocreartuweb.es es quien se encarga del soporte de dicho hosting.

si podemos ayudarle en alguna otra cosa, contactenos de nuevo
Pero si sólo ellos pueden modificar ciertos archivos del servidor, los usuarios sólo podemos modificar los archivos públicos, no? :confused:
Probaste a crear el directorio con el archivo a ver qué pasa?
En el directorio home, en el public y en php, pero no, no ha funcionado. Que no sea por probar
[;)]
Pues entonces ni idea, siento mucho no poder ayudarte :(
A ver si alguien que sepa más se pasa por aquí y te resuelve la duda, suerte!!
Doodleo escribió:Pues entonces ni idea, siento mucho no poder ayudarte :(
A ver si alguien que sepa más se pasa por aquí y te resuelve la duda, suerte!!

Pues no tienes que sentirlo, porque me has ayudado, al menos ahora sé de qué va el tema, que hasta ahora pensaba que podría ser cosa mía.

Gracias por todo, les he enviado otro mensaje a los de Sered a ver si pueden solucionar algo.
por que no checas en directorio raiz / a veces se guardan algunas carpetas tal vez este la carpeta que buscas
to0xiick-dc escribió:por que no checas en directorio raiz / a veces se guardan algunas carpetas tal vez este la carpeta que buscas

¿El directorio raiz?, ése directorio no es accesible para los usuarios, lo más alto que se puede llegar es a /home/"usuario"/

A la pregunta que les hice a los de SERED de si pueden comprobar si existe el directorio y archivo que se mencionan en este hilo no me han respondido, lo que sí han hecho es cerrar el ticket
[:(]
Después de estar leyendo algo por aquí y por allí, creo que la causa de que no funcionen los cron es el comando que he utilizado hasta ahora y que no es compatible con la última actualización de PHP. Yo siempre he utilizado este comando para ejecutar lo cron:
php -f /home/....

hoy he probado a utilizar:
wget http://www.....

y parece que funciona. Obviamente no es lo que me gusta, prefiero el primer sistema que permite tener los archivos del cron fuera de la carpeta public, pero si no hay otra solución, tendré que adaptarme.

¿puede ser que con la última actualización de PHP ya no funcionen los comandos php -f?
¿existe otro modo de ejecutar archivos php que estén por encima del nivel public?
¿se debe utilizar algún otro parámetro en el comando php para que funcione?

He visto en algunas páginas que se utiliza /usr/local/bin/php, ¿alguien utiliza este tipo de comandos o sólo los wget?